# HG changeset patch
# Parent 44546ef161af3817dd5c24513c351e9cc4323633
--- a/mail/themes/gnomestripe/jar.mn
+++ b/mail/themes/gnomestripe/jar.mn
@@ -71,8 +71,30 @@ classic.jar:
skin/classic/messenger/addressbook/icons/ablist.png (mail/addrbook/ablist.png)
skin/classic/messenger/addressbook/icons/contact-generic.png (mail/addrbook/contact-generic.png)
skin/classic/messenger/addressbook/icons/contact-generic-tiny.png (mail/addrbook/contact-generic-tiny.png)
- skin/classic/messenger/addressbook/icons/addressbook-toolbar.png (mail/addrbook/addressbook-toolbar.png)
- skin/classic/messenger/addressbook/icons/addressbook-toolbar-small.png (mail/addrbook/addressbook-toolbar-small.png)
+ skin/classic/messenger/addressbook/icons/button-info-disabled.svg (mail/addrbook/button-info-disabled.svg)
+ skin/classic/messenger/addressbook/icons/button-info-hover.svg (mail/addrbook/button-info-hover.svg)
+ skin/classic/messenger/addressbook/icons/button-info-small-disabled.svg (mail/addrbook/button-info-small-disabled.svg)
+ skin/classic/messenger/addressbook/icons/button-info-small-hover.svg (mail/addrbook/button-info-small-hover.svg)
+ skin/classic/messenger/addressbook/icons/button-info-small.svg (mail/addrbook/button-info-small.svg)
+ skin/classic/messenger/addressbook/icons/button-info.svg (mail/addrbook/button-info.svg)
+ skin/classic/messenger/addressbook/icons/button-newcard-disabled.svg (mail/addrbook/button-newcard-disabled.svg)
+ skin/classic/messenger/addressbook/icons/button-newcard-hover.svg (mail/addrbook/button-newcard-hover.svg)
+ skin/classic/messenger/addressbook/icons/button-newcard-small-disabled.svg (mail/addrbook/button-newcard-small-disabled.svg)
+ skin/classic/messenger/addressbook/icons/button-newcard-small-hover.svg (mail/addrbook/button-newcard-small-hover.svg)
+ skin/classic/messenger/addressbook/icons/button-newcard-small.svg (mail/addrbook/button-newcard-small.svg)
+ skin/classic/messenger/addressbook/icons/button-newcard.svg (mail/addrbook/button-newcard.svg)
+ skin/classic/messenger/addressbook/icons/button-newim-disabled.svg (mail/addrbook/button-newim-disabled.svg)
+ skin/classic/messenger/addressbook/icons/button-newim-hover.svg (mail/addrbook/button-newim-hover.svg)
+ skin/classic/messenger/addressbook/icons/button-newim-small-disabled.svg (mail/addrbook/button-newim-small-disabled.svg)
+ skin/classic/messenger/addressbook/icons/button-newim-small-hover.svg (mail/addrbook/button-newim-small-hover.svg)
+ skin/classic/messenger/addressbook/icons/button-newim-small.svg (mail/addrbook/button-newim-small.svg)
+ skin/classic/messenger/addressbook/icons/button-newim.svg (mail/addrbook/button-newim.svg)
+ skin/classic/messenger/addressbook/icons/button-newlist-disabled.svg (mail/addrbook/button-newlist-disabled.svg)
+ skin/classic/messenger/addressbook/icons/button-newlist-hover.svg (mail/addrbook/button-newlist-hover.svg)
+ skin/classic/messenger/addressbook/icons/button-newlist-small-disabled.svg (mail/addrbook/button-newlist-small-disabled.svg)
+ skin/classic/messenger/addressbook/icons/button-newlist-small-hover.svg (mail/addrbook/button-newlist-small-hover.svg)
+ skin/classic/messenger/addressbook/icons/button-newlist-small.svg (mail/addrbook/button-newlist-small.svg)
+ skin/classic/messenger/addressbook/icons/button-newlist.svg (mail/addrbook/button-newlist.svg)
skin/classic/messenger/addressbook/icons/abcard-large.png (mail/addrbook/abcard-large.png)
skin/classic/messenger/addressbook/icons/remote-addrbook.png (mail/addrbook/remote-addrbook.png)
skin/classic/messenger/addressbook/icons/remote-addrbook-error.png (mail/addrbook/remote-addrbook-error.png)
--- a/mail/themes/gnomestripe/mail/addrbook/addressbook.css
+++ b/mail/themes/gnomestripe/mail/addrbook/addressbook.css
@@ -71,111 +71,185 @@ toolbox[labelalign="end"] > toolbar[mode
}
#button-newcard {
- list-style-image: url("chrome://messenger/skin/addressbook/icons/addressbook-toolbar.png");
- -moz-image-region: rect(44px 22px 66px 0px); /* contact-add.png */
+ list-style-image: url("chrome://messenger/skin/addressbook/icons/button-newcard.svg") !important;
+ -moz-image-region: auto !important;
+}
+
+#button-newcard:hover {
+ list-style-image: url("chrome://messenger/skin/addressbook/icons/button-newcard-hover.svg") !important;
+ -moz-image-region: auto !important;
}
#button-newcard[disabled="true"] {
- -moz-image-region: rect(66px 22px 88px 0px); /* contact-add-disabled.png */
-}
+ list-style-image: url("chrome://messenger/skin/addressbook/icons/button-newcard-disabled.svg") !important;
+ -moz-image-region: auto !important;
+}
#button-newlist {
- list-style-image: url("chrome://messenger/skin/addressbook/icons/addressbook-toolbar.png");
- -moz-image-region: rect(88px 22px 110px 0px); /* contact-list-add.png */
+ list-style-image: url("chrome://messenger/skin/addressbook/icons/button-newlist.svg") !important;
+ -moz-image-region: auto !important;
+}
+
+#button-newlist:hover {
+ list-style-image: url("chrome://messenger/skin/addressbook/icons/button-newlist-hover.svg") !important;
+ -moz-image-region: auto !important;
}
#button-newlist[disabled="true"] {
- -moz-image-region: rect(110px 22px 132px 0px); /* contact-list-add-disabled.png */
-}
+ list-style-image: url("chrome://messenger/skin/addressbook/icons/button-newlist-disabled.svg") !important;
+ -moz-image-region: auto !important;
+}
#button-editcard {
- list-style-image: url("chrome://messenger/skin/addressbook/icons/addressbook-toolbar.png");
- -moz-image-region: rect(132px 22px 154px 0px); /* contact-properties.png */
+ list-style-image: url("chrome://messenger/skin/addressbook/icons/button-info.svg") !important;
+ -moz-image-region: auto !important;
+}
+
+#button-editcard:hover {
+ list-style-image: url("chrome://messenger/skin/addressbook/icons/button-info-hover.svg") !important;
+ -moz-image-region: auto !important;
}
#button-editcard[disabled="true"] {
- -moz-image-region: rect(154px 22px 176px 0px); /* contact-properties-disabled.png */
+ list-style-image: url("chrome://messenger/skin/addressbook/icons/button-info-disabled.svg") !important;
+ -moz-image-region: auto !important;
}
#button-newmessage {
- list-style-image: url("chrome://messenger/skin/addressbook/icons/addressbook-toolbar.png");
- -moz-image-region: rect(176px 22px 198px 0px); /* message-compose.png */
+ list-style-image: url("chrome://messenger/skin/icons/button-newmsg.svg") !important;
+ -moz-image-region: auto !important;
+}
+
+#button-newmessage:hover {
+ list-style-image: url("chrome://messenger/skin/icons/button-newmsg-hover.svg") !important;
+ -moz-image-region: auto !important;
}
-#button-newmessage[disabled] {
- -moz-image-region: rect(198px 22px 220px 0px); /* message-compose-disabled.png */
+#button-newmessage[disabled="true"] {
+ list-style-image: url("chrome://messenger/skin/icons/button-newmsg-disabled.svg") !important;
+ -moz-image-region: auto !important;
}
#button-newim {
- list-style-image: url("chrome://messenger/skin/addressbook/icons/addressbook-toolbar.png");
- -moz-image-region: rect(0px 22px 22px 0px); /* chat-new.png */
+ list-style-image: url("chrome://messenger/skin/addressbook/icons/button-newim.svg") !important;
+ -moz-image-region: auto !important;
}
-#button-newim[disabled] {
- -moz-image-region: rect(22px 22px 44px 0px); /* chat-new-disabled.png */
-}
+#button-newim:hover {
+ list-style-image: url("chrome://messenger/skin/addressbook/icons/button-newim-hover.svg") !important;
+ -moz-image-region: auto !important;
+}
+
+#button-newim[disabled="true"] {
+ list-style-image: url("chrome://messenger/skin/addressbook/icons/button-newim-disabled.svg") !important;
+ -moz-image-region: auto !important;
+}
#button-abdelete {
- list-style-image: url("moz-icon://stock/gtk-delete?size=toolbar")
+ list-style-image: url("chrome://messenger/skin/icons/button-delete.svg") !important;
+ -moz-image-region: auto !important;
}
-#button-abdelete[disabled] {
- list-style-image: url("moz-icon://stock/gtk-delete?size=toolbar&state=disabled")
+#button-abdelete:hover {
+ list-style-image: url("chrome://messenger/skin/icons/button-delete-hover.svg") !important;
+ -moz-image-region: auto !important;
+}
+
+#button-abdelete[disabled="true"] {
+ list-style-image: url("chrome://messenger/skin/icons/button-delete-disabled.svg") !important;
+ -moz-image-region: auto !important;
}
/* ::::: small primary toolbar buttons ::::: */
toolbar[iconsize="small"] #button-newcard {
- list-style-image: url("chrome://messenger/skin/addressbook/icons/addressbook-toolbar-small.png");
- -moz-image-region: rect(32px 16px 48px 0px); /* contact-add-small.png */
+ list-style-image: url("chrome://messenger/skin/addressbook/icons/button-newcard-small.svg") !important;
+ -moz-image-region: auto !important;
+}
+
+toolbar[iconsize="small"] #button-newcard:hover {
+ list-style-image: url("chrome://messenger/skin/addressbook/icons/button-newcard-small-hover.svg") !important;
+ -moz-image-region: auto !important;
}
-toolbar[iconsize="small"] #button-newcard[disabled] {
- -moz-image-region: rect(48px 16px 64px 0px); /* contact-add-small-disabled.png */
+toolbar[iconsize="small"] #button-newcard[disabled="true"] {
+ list-style-image: url("chrome://messenger/skin/addressbook/icons/button-newcard-small-disabled.svg") !important;
+ -moz-image-region: auto !important;
}
toolbar[iconsize="small"] #button-newlist {
- list-style-image: url("chrome://messenger/skin/addressbook/icons/addressbook-toolbar-small.png");
- -moz-image-region: rect(64px 16px 80px 0px); /* contact-list-add-small.png */
+ list-style-image: url("chrome://messenger/skin/addressbook/icons/button-newlist-small.svg") !important;
+ -moz-image-region: auto !important;
}
-toolbar[iconsize="small"] #button-newlist[disabled] {
- -moz-image-region: rect(80px 16px 96px 0px); /* contact-list-add-small-disabled.png */
+toolbar[iconsize="small"] #button-newlist:hover {
+ list-style-image: url("chrome://messenger/skin/addressbook/icons/button-newlist-small-hover.svg") !important;
+ -moz-image-region: auto !important;
+}
+
+toolbar[iconsize="small"] #button-newlist[disabled="true"] {
+ list-style-image: url("chrome://messenger/skin/addressbook/icons/button-newlist-small-disabled.svg") !important;
+ -moz-image-region: auto !important;
}
toolbar[iconsize="small"] #button-editcard {
- list-style-image: url("chrome://messenger/skin/addressbook/icons/addressbook-toolbar-small.png");
- -moz-image-region: rect(96px 16px 112px 0px); /* contact-properties-small.png */
+ list-style-image: url("chrome://messenger/skin/addressbook/icons/button-info-small.svg") !important;
+ -moz-image-region: auto !important;
+}
+
+toolbar[iconsize="small"] #button-editcard:hover {
+ list-style-image: url("chrome://messenger/skin/addressbook/icons/button-info-small-hover.svg") !important;
+ -moz-image-region: auto !important;
}
toolbar[iconsize="small"] #button-editcard[disabled="true"] {
- -moz-image-region: rect(112px 16px 128px 0px); /* contact-properties-small-disabled.png */
+ list-style-image: url("chrome://messenger/skin/addressbook/icons/button-info-small-disabled.svg") !important;
+ -moz-image-region: auto !important;
}
toolbar[iconsize="small"] #button-newmessage {
- list-style-image: url("chrome://messenger/skin/addressbook/icons/addressbook-toolbar-small.png");
- -moz-image-region: rect(128px 16px 144px 0px); /* message-compose-small.png */
+ list-style-image: url("chrome://messenger/skin/icons/button-newmsg-small.svg") !important;
+ -moz-image-region: auto !important;
}
-toolbar[iconsize="small"] #button-newmessage[disabled] {
- -moz-image-region: rect(144px 16px 160px 0px); /* message-compose-small-disabled.png */
+toolbar[iconsize="small"] #button-newmessage:hover {
+ list-style-image: url("chrome://messenger/skin/icons/button-newmsg-small-hover.svg") !important;
+ -moz-image-region: auto !important;
+}
+
+toolbar[iconsize="small"] #button-newmessage[disabled="true"] {
+ list-style-image: url("chrome://messenger/skin/icons/button-newmsg-small-disabled.svg") !important;
+ -moz-image-region: auto !important;
}
toolbar[iconsize="small"] #button-newim {
- list-style-image: url("chrome://messenger/skin/addressbook/icons/addressbook-toolbar-small.png");
- -moz-image-region: rect(0px 16px 16px 0px); /* chat-new-small.png */
+ list-style-image: url("chrome://messenger/skin/addressbook/icons/button-newim-small.svg") !important;
+ -moz-image-region: auto !important;
+}
+
+toolbar[iconsize="small"] #button-newim:hover {
+ list-style-image: url("chrome://messenger/skin/addressbook/icons/button-newim-small-hover.svg") !important;
+ -moz-image-region: auto !important;
}
-toolbar[iconsize="small"] #button-newim[disabled] {
- -moz-image-region: rect(16px 16px 32px 0px); /* chat-new-small-disabled.png */
+toolbar[iconsize="small"] #button-newim[disabled="true"] {
+ list-style-image: url("chrome://messenger/skin/addressbook/icons/button-newim-small-disabled.svg") !important;
+ -moz-image-region: auto !important;
}
toolbar[iconsize="small"] #button-abdelete {
- list-style-image: url("moz-icon://stock/gtk-delete?size=menu");
+ list-style-image: url("chrome://messenger/skin/icons/button-delete-small.svg") !important;
+ -moz-image-region: auto !important;
+}
+
+toolbar[iconsize="small"] #button-abdelete:hover {
+ list-style-image: url("chrome://messenger/skin/icons/button-delete-small-hover.svg") !important;
+ -moz-image-region: auto !important;
}
-toolbar[iconsize="small"] #button-abdelete[disabled] {
- list-style-image: url("moz-icon://stock/gtk-delete?size=menu&state=disabled");
+toolbar[iconsize="small"] #button-abdelete[disabled="true"] {
+ list-style-image: url("chrome://messenger/skin/icons/button-delete-small-disabled.svg") !important;
+ -moz-image-region: auto !important;
}
#abContent {
@@ -349,25 +423,25 @@ html|p {
#menu_newContact,
#dirTreeContext-newcard {
- list-style-image: url("chrome://messenger/skin/addressbook/icons/addressbook-toolbar-small.png");
- -moz-image-region: rect(32px 16px 48px 0px); /* contact-add-small.png */
+ list-style-image: url("chrome://messenger/skin/addressbook/icons/button-newcard-small.svg") !important;
+ -moz-image-region: auto !important;
}
#menu_newList,
#dirTreeContext-newlist {
- list-style-image: url("chrome://messenger/skin/addressbook/icons/addressbook-toolbar-small.png");
- -moz-image-region: rect(64px 16px 80px 0px); /* contact-list-add-small.png */
+ list-style-image: url("chrome://messenger/skin/addressbook/icons/button-newlist-small.svg") !important;
+ -moz-image-region: auto !important;
}
#menu_newMessage,
#abResultsTreeContext-newmessage {
- list-style-image: url("chrome://messenger/skin/addressbook/icons/addressbook-toolbar-small.png");
- -moz-image-region: rect(128px 16px 144px 0px); /* message-compose-small.png */
+ list-style-image: url("chrome://messenger/skin/icons/button-newmsg-small.svg") !important;
+ -moz-image-region: auto !important;
}
#abResultsTreeContext-newim {
- list-style-image: url("chrome://messenger/skin/addressbook/icons/addressbook-toolbar-small.png");
- -moz-image-region: rect(0px 16px 16px 0px); /* chat-new-small.png */
+ list-style-image: url("chrome://messenger/skin/addressbook/icons/button-newim-small.svg") !important;
+ -moz-image-region: auto !important;
}
#menu_search_addresses {
@@ -377,8 +451,8 @@ html|p {
#menu_properties,
#dirTreeContext-properties,
#abResultsTreeContext-properties {
- list-style-image: url("chrome://messenger/skin/addressbook/icons/addressbook-toolbar-small.png");
- -moz-image-region: rect(96px 16px 112px 0px); /* contact-properties-small.png */
+ list-style-image: url("chrome://messenger/skin/addressbook/icons/button-info-small.svg") !important;
+ -moz-image-region: auto !important;
}
#dirTreeContext-delete,
--- /dev/null
+++ b/mail/themes/gnomestripe/mail/addrbook/button-info-disabled.svg
@@ -0,0 +1,7 @@
+
--- /dev/null
+++ b/mail/themes/gnomestripe/mail/addrbook/button-info-hover.svg
@@ -0,0 +1,7 @@
+
--- /dev/null
+++ b/mail/themes/gnomestripe/mail/addrbook/button-info-small-disabled.svg
@@ -0,0 +1,7 @@
+
--- /dev/null
+++ b/mail/themes/gnomestripe/mail/addrbook/button-info-small-hover.svg
@@ -0,0 +1,7 @@
+
--- /dev/null
+++ b/mail/themes/gnomestripe/mail/addrbook/button-info-small.svg
@@ -0,0 +1,7 @@
+
--- /dev/null
+++ b/mail/themes/gnomestripe/mail/addrbook/button-info.svg
@@ -0,0 +1,7 @@
+
--- /dev/null
+++ b/mail/themes/gnomestripe/mail/addrbook/button-newcard-disabled.svg
@@ -0,0 +1,7 @@
+
--- /dev/null
+++ b/mail/themes/gnomestripe/mail/addrbook/button-newcard-hover.svg
@@ -0,0 +1,7 @@
+
--- /dev/null
+++ b/mail/themes/gnomestripe/mail/addrbook/button-newcard-small-disabled.svg
@@ -0,0 +1,7 @@
+
--- /dev/null
+++ b/mail/themes/gnomestripe/mail/addrbook/button-newcard-small-hover.svg
@@ -0,0 +1,7 @@
+
--- /dev/null
+++ b/mail/themes/gnomestripe/mail/addrbook/button-newcard-small.svg
@@ -0,0 +1,7 @@
+
--- /dev/null
+++ b/mail/themes/gnomestripe/mail/addrbook/button-newcard.svg
@@ -0,0 +1,7 @@
+
--- /dev/null
+++ b/mail/themes/gnomestripe/mail/addrbook/button-newim-disabled.svg
@@ -0,0 +1,7 @@
+
--- /dev/null
+++ b/mail/themes/gnomestripe/mail/addrbook/button-newim-hover.svg
@@ -0,0 +1,7 @@
+
--- /dev/null
+++ b/mail/themes/gnomestripe/mail/addrbook/button-newim-small-disabled.svg
@@ -0,0 +1,7 @@
+
--- /dev/null
+++ b/mail/themes/gnomestripe/mail/addrbook/button-newim-small-hover.svg
@@ -0,0 +1,7 @@
+
--- /dev/null
+++ b/mail/themes/gnomestripe/mail/addrbook/button-newim-small.svg
@@ -0,0 +1,7 @@
+
--- /dev/null
+++ b/mail/themes/gnomestripe/mail/addrbook/button-newim.svg
@@ -0,0 +1,7 @@
+
--- /dev/null
+++ b/mail/themes/gnomestripe/mail/addrbook/button-newlist-disabled.svg
@@ -0,0 +1,7 @@
+
--- /dev/null
+++ b/mail/themes/gnomestripe/mail/addrbook/button-newlist-hover.svg
@@ -0,0 +1,7 @@
+
--- /dev/null
+++ b/mail/themes/gnomestripe/mail/addrbook/button-newlist-small-disabled.svg
@@ -0,0 +1,7 @@
+
--- /dev/null
+++ b/mail/themes/gnomestripe/mail/addrbook/button-newlist-small-hover.svg
@@ -0,0 +1,7 @@
+
--- /dev/null
+++ b/mail/themes/gnomestripe/mail/addrbook/button-newlist-small.svg
@@ -0,0 +1,7 @@
+
--- /dev/null
+++ b/mail/themes/gnomestripe/mail/addrbook/button-newlist.svg
@@ -0,0 +1,7 @@
+
--- a/mail/themes/gnomestripe/mail/messenger.css
+++ b/mail/themes/gnomestripe/mail/messenger.css
@@ -158,8 +158,8 @@ menuitem:not([type]) {
}
#menu_newCard {
- list-style-image: url("chrome://messenger/skin/addressbook/icons/addressbook-toolbar.png");
- -moz-image-region: rect(44px 22px 66px 0px); /* contact-add.png */
+ list-style-image: url("chrome://messenger/skin/addressbook/icons/button-newcard.svg") !important;
+ -moz-image-region: auto !important;
}
#openMessageFileMenuitem {
--- a/mail/themes/gnomestripe/mail/compose/messengercompose.css
+++ b/mail/themes/gnomestripe/mail/compose/messengercompose.css
@@ -665,13 +665,13 @@ toolbarbutton.formatting-button {
/** Stock icons for the menu items. */
#menu_NewMessage {
- list-style-image: url("chrome://messenger/skin/addressbook/icons/addressbook-toolbar.png");
- -moz-image-region: rect(176px 22px 198px 0px); /* message-compose.png */
+ list-style-image: url("chrome://messenger/skin/icons/button-newmsg-small.svg") !important;
+ -moz-image-region: auto !important;
}
#menu_NewContact {
- list-style-image: url("chrome://messenger/skin/addressbook/icons/addressbook-toolbar.png");
- -moz-image-region: rect(44px 22px 66px 0px); /* contact-add.png */
+ list-style-image: url("chrome://messenger/skin/addressbook/icons/button-newcard-small.svg") !important;
+ -moz-image-region: auto !important;
}
#menu_SaveCmd {